スポンサーリンク


ある自分のサイトだが、ログインしたら次のような文字が画面の先頭に現れた。エラー表示の画面だ。

Warning: Declaration of WPPopularPostsWidget::update($new_instance) should be compatible with WP_Widget::update($new_instance, $old_instance)

このところ、エラー表示の画面がでたりとそんなことばかり続く。そのようなときは、たいていはXSERVER のサーバーパネルにはいり、「PHPバージョン切り替え」の項目で、最新のバージョンである「PHP7.2.6」にするとうまく行ったのだ。しかし、このサイトはすでに「PHP7.2.6」と最新のバージョンにしてある。どうもその関係ではなさそうだ。

警告(Warning)の先頭をみると、どうやら WPPopularPostsWidgetが問題がありそうだ。それでプラグインとして用いているWP Popular Posts の「詳細を表示」のボタンをクリックすると以下のようである。

プラグイン

7年前に更新されたきりのプラグインである。そして、「このプラグインは現在使用しているWordPressのバージョンではテストされていません」とある。この場合はプラグインが古くなって最新のWPのバージョン、あるいは「PHP7.2.6」に合わなくなったようだ。

このプラグインを取り除くと、無事に画面の先頭の警告の英文は消えた。

教訓としては、WP, PHP のバージョンを新しくしていくと、更新していないプラグインとは齟齬をきたす。その時は、プラグインを取り除くべきである。逆にプラグインを更新しているが、PHPの更新を怠っている場合は、同様に齟齬をきたし、英文の警告文がでるので、PHPのバージョンを更新すべきである。