スポンサーリンク


PHPの版が古いので、Pixabayというプラグインを導入(or 更新)しようとしたら、エラーになったという話をした。

それ故に、時々は1年に一回は、管理画面(XSERVER のserver panel の管理画面)にて、PHP .Verを更新するために切り替えを行うべきだ。

自分のサイトで3年ぐらいに前に購入したドメインは5.5.3版であり、Pixabay の更新に対応できていなかった。そのためにエラーが出たのだ。

今年初めに購入したドメインはすでに版は7.2.3であり、特に問題はなかった。 

しかし、やはり問題があると思う。それは、作者がプラグインを更新するときは、過去のWordPress の版との継続性を意識してほしいと言うことだ。つまり、できるだけ連続性が出るようにしてほしい。

また、XSERVERだが、これは自動的にPHPのバージョンアップをしてもらえないか。WP自体はよく自動更新がおこなわれる。しかし、PHPのバージョンアップは自動ではない。このことは全然知らなかった。

とにかく、ブログやサイトの書き方でもかなり深いようだ。自分はいろいろと勉強しなければならないことがたくさんある。

Free-Photos / Pixabay